6

I was browsing around on a few recent questions when this caught my eye:

Blank sidebar links

  • Those are blank links.
  • Clicking the blank ones takes me directly to answers.
  • The vote counts represent the answer's count (rather than the question's count).
  • The link with words takes me to a question

I didn't think that the Related tab could link directly to answers? That may be the bug, but if this is meant to be a new feature, then there should at least be text next to the vote counts.

Here is the question in question. I haven't been able to find another example just yet.

  • That's weird. I don't see anything wrong when I go to that linked question - all the related links work fine. Maybe it's a browser issue? I'm using Chrome v61.0.3163.91. – Mage Xy Sep 15 '17 at 14:15
  • 1
    I was able to reproduce earlier today but not anymore. – Invader Skoodge Sep 15 '17 at 14:50
  • 1
    Looks like its been fixed. – Frank Sep 15 '17 at 15:10
  • Thanks for the update @Frank – Robotnik Sep 15 '17 at 16:19
2

This has now been fixed:

A recent refactor of how we do Elastic searches for related questions was referencing the wrong site (using Current.Site rather than a site passed to the operation) during the refresh process for a question. This led to seemingly random post identifiers being used for the related questions. When we came to render the URL it went one of a few ways:

  • It couldn't find the question and so ignored it
  • The PostId was actually that of an answer and so it didn't have a title
  • The PostId was that of another type of post used for things like help posts (which are localized)

Eurgh. We've fixed it, purged caches and all is now well.

Thanks for the heads up <3
- Dean Ward ♦ - Meta Stack Exchange

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .