3

When clicking on the "next" button at the bottom of the users page, to go to the next page of users, the filters aren't preserved.

Steps to reproduce:

  1. Go to the users page at http://gaming.stackexchange.com/users

  2. Set the filter to 'all' by clicking 'all' at the top.

    picture of the page with the 'all' link circled freehand

    The URL of the page is now http://gaming.stackexchange.com/users?tab=reputation&filter=all

  3. Click 'next' at the bottom of the page.

    picture of the page with the 'next' link circled freehand

  4. Notice that it's no longer filtering by 'all'. The URL is mangled: http://gaming.stackexchange.com/users?page=2&tab=reputation&filter=all.

    picture of the page with 'month' chosen and a freehand frowny face

If you un-escape the ampersands in the final link, it fixes the URL. Clicking the link, however, has them escaped and thus renders the wrong page.

| |
  • This is an engine-wide problem and should be posted on meta.stackoverflow.com – Resorath Aug 30 '13 at 21:41
  • @Resorath The mods can migrate if they want. I don't really use other sites so I post problems I find here. – Invader Skoodge Aug 30 '13 at 21:41
  • 2
    Actually this has already been reported; meta.stackexchange.com/questions/195306/… posting on meta stackoverflow will get you more attention. – Resorath Aug 30 '13 at 21:41
  • 5
    @Resorath No. Engine Bugs can be posted on per-site metas. All per site metas are monitored by devs for bug reports. This is a perfectly cromulent post. Not everything needs to go to MSO. In fact, next to nothing needs to go to MSO. – LessPop_MoreFizz Aug 30 '13 at 23:04

You must log in to answer this question.

Browse other questions tagged .