2

I know this is my 3rd post here in a few days but I think this could also help things get closer to this agreement.

Right now whenever question about Minecraft Java is posted the version is implied if no version is specified. This is good. But, in a few months/years someone searching this up will click it and see "How do I X" and then see an answer telling them how to do it. Now, let's say the searcher is using 1.17 but the question was asked during 1.15. The answers and question at the time had the implied version, but the searcher doesn't know that. (I know there is timestamps, but your random kid googling it isn't going to pay attention to that.)

So... what if all questions asked contained the version? If the version is omitted, what if someone who can easily edit edited in the version in all the questions with an implied versions? If the question wants multiple versions, then maybe the question can omit the version, but at the very least the answer should (if people agree with this) almost always have the version labeled.

What do people think about this?

5
  • 2
    I know this is my 3rd post here in a few days Nothing wrong with being a frequent meta poster.
    – Wipqozn Mod
    Nov 25 '20 at 21:22
  • Recent example: gaming.stackexchange.com/questions/367625/… (Some additional context is I posted this bounty in response to some NAA flags on a now deleted answer asking "How do we do it in 1.16.4 now?")
    – Wipqozn Mod
    Nov 25 '20 at 21:23
  • @Wipqozn yes and I believe that there is just 1 problem with that bounty: it asks for a 1.15 question. The question should probably be edited then to ask for both versions because bounties are temporary. What do you think? As long as the answer is labeled, though, it could be alright to have the question maybe unclear?
    – Penguin
    Nov 25 '20 at 21:36
  • I'd rather have the question labeled and only label future answers about newer versions. Most older questions don't get updated answers and having the version in the question body improves readability and the search results.
    – dly
    Nov 27 '20 at 6:25
  • This seems to be related, why should this answer not have it labeled 1.15 if it doesn’t work in the latest version, which is also asked for? It apparently is “not the author’s intent”, but why?
    – Penguin
    Nov 29 '20 at 19:24

You must log in to answer this question.

Browse other questions tagged .