3

I was trying to go and chat with people on Arqade, but I went to a chat room (Summoner's Rift) and it said you need to be logged in to chat, I pressed login and got to the auto login page, waited for ~30 minutes with nothing happening and pressed the link that says "visit the GlobalAuth test & help page" on that auto login page.

The link takes me to: http://chat.stackexchange.com/help

It says all the test pass but still I can't login to chat, any insight why? Stack Overflow chat works fine, don't have enough rep on other sites to try.

I also tried logging out and then logging back in as suggested on the chat help page.

  • You have enough rep here to chat all over stackexchange, so that's not the issue – Arperum May 27 '15 at 12:38
  • Try a different browser, clearing cache and cookies? – Mathias711 May 27 '15 at 19:15
  • Original problem with Firefox, tried IE as well. Clearing cache and cookies did no good. – Slyre May 28 '15 at 8:17

You must log in to answer this question.

Browse other questions tagged .